VirtualR.net - 100% Independent Sim Racing News
Mosport 2009 All Platforms – Released

Mosport 2009 All Platforms – Released

NeelJ has released his Mosport 2009 track for rFactor, GT2 & GTR Evolution/Race07, adding the popular Canadian race track to several popular simulations.

Based on a Nascar Racing 2003 version of the track, the track has been majorly revamped using real-life photos.

Located north of Bowmanville, Ontario, Mosport is one of Canada’s most famous motorsport venues. The 4 kilometer track layout includes 10 turns and is one of the very few classical racetracks that remained almost completely unchanged over the years.

The track has a rich history both in terms of Formula One and sports cars, hosting the Canadian Grand Prix until 1977 and still being a very active sports car racing venue today.

Download Mosport 2009 for rFactor Here

Dowload Mosport 2009 for GTR2 Here

Download Mosport 2009 for GTR Evolution / Race07 Here

Download Mosport 2009 for GT Legends Here

  • http://simracing.in.ua Pandamasque

    “Treeeees! Liiiife!”

    😆

  • Nimrod

    Wonderful track, also available for GT Legends:

    http://www.nogripracing.com/details.php?filenr=26256

    thank you NeelJ.

  • Neel_Jani

    Hi Nimrod

    Thanks

    Cheers,
    Neel Jani

  • logos

    Thanks for supporting all gMotor2 sims, Neel! Top quality work, as usual!
    IMO, this is the best recreation of the modern Mosport for the gMotor2 platform.
    Well done! :happy:

  • Neel_Jani

    Hi logos,

    Thanks :happy:

  • mjmueller

    Very good Layout and Graphics. We have tested it with the SP-1 Enduracers mod & there seems to be a few problems. First off the track uses a lot of Memory. Also, I get bad fps ingame & there seems to be some stuttering. Do you plan to optimize for the future? I really hope so because it’s the best Mosport out there.

    mj

  • ZombieJim

    Been looking forward to the rFactor version!

    This is definitely a track I’m going to work to master, if I can. It’s a brilliant layout and the graphics are superb.

    I would like to mirror mjmueller‘s comment about FPS though. There seem to be oddly high-poly models throughout the track which, while beautiful to look at, give my poor old graphics card a savage beating.

    The good far outweighs the bad, and this really seems like a labour of love. Thank you for giving us an amazing piece of work. I’m enjoying it immensely.

  • http://simracing.in.ua Pandamasque

    Neel, great job, first of all. I have found another problem though (rF version). There’s some flickering when using cockpit camera. Mainly around turns 5-6 (the slow bit). Some AD boards and the ‘racegroove’ flicker at a certain distance.

  • Neel_Jani

    ZombieJim: Been looking forward to the rFactor version!This is definitely a track I’m going to work to master, if I can. It’s a brilliant layout and the graphics are superb.
    I would like to mirror mjmueller’s comment about FPS though. There seem to be oddly high-poly models throughout the track which, while beautiful to look at, give my poor old graphics card a savage beating.The good far outweighs the bad, and this really seems like a labour of love. Thank you for giving us an amazing piece of work. I’m enjoying it immensely.

    Hello,

    Thank you for your remarks,

    On the other hand we tested the circuit on several machine and without having main issue of FPS and with a full grid,
    In these test a player stays of resolution 1920×1024 any detail of the play to the maximum on PC a three year old with good interior FPS in sight,

    It would be necessary for you to show a test with cars of origin in order to the difference because it board not forcing and always the circuit causes some but also the MOD with of Skins HD, but what I then to say it is that it and not simple to satisfy all the players and especially if they have a little weak configurations,

    We cannot currently rained considering the request of more by players who have one of the large configurations to make circuits as it was made it I at three years and which required less resource,

    Afflicted for my bad English,

    Cheers,
    Neel

  • http://www.mini-z.be HaCo

    Can someone tell me what the first mod is with the muscle cars?
    Thanks.

  • http://hompe.blogspot.com Hompe

    HaCo: Can someone tell me what the first mod is with the muscle cars?Thanks.

    Its the game “race on” by simbin

  • F1_fan_1

    Lovely. Big improvement over the last version. I love the flow of this track. I’d recommend the Epsilon Euskadi P1 car for this track. :happyevil:

  • CrippleHorse

    Hi, Neel_Jani. I have a fairly above-average PC and FPS drops to the 40’s in every corner, except after Moss where I get 28 driving the SCGT mod without opponents. Should still be drivable for the most part but the drops are so sudden that I have trouble steering. Furthermore, it’s the only track I’ve ever had issues with, so I guess that the majority of people are going to have similar problems, not just the ones with old PCs. Don’t get me wrong, I do think it’s a very nice looking track, just providing my feedback, hoping it helps.

  • I have a GTX 260 and also get stuttering issues with this track, it also seems to take a lot longer to load than any other rFactor track, other than that it is awesome.

  • raceralexuk

    Great track, great representation of the place. Really fun to drive. I have no graphical problems with it whatsoever, but the biggest gripe I have is that the AI don’t know how to drive through Corner 5A and Moss Corner. With all mods I’ve tested the AI are hustling me arond the whole track, but loose a good second and a half around the aforementioned section.

  • https://www.virtualr.net Montoya

    Nimrod: Wonderful track, also available for GT Legends:http://www.nogripracing.com/details.php?filenr=26256thank you NeelJ.

    Whoops, overlook that – Fixed, thanks! 😀

  • GeraArg

    Nice job. 😎 😎 😎

  • Joao Barbosa

    Great track, well done. Thanks.

    No problemas here, with performance, flickering, etc. Tested with F1 1985 and Historic GT&TC, 17 AIs.
    WinXP SP3, [email protected], ATI Radeon HD [email protected]×1050, 2xAA, 4xAF.

  • tigeraid

    I’ve been to Mosport several times and this is by far the most accurate version of it I’ve ever seen, and very up to date–most of the banners are accurate as of last summer, the gravel trap at Moss is correct, and you even included washrooms! 😆

    I too am noticing small slowdowns in FPS too, a little bit at Moss and a little bit at Turn 10… With a full field of cars it’s a noticeable lag, which may prevent efnet#cars from running this Mosport next season… Here’s to hoping you can release a minor fix that tones down the polys a little! 😎

  • Neel_Jani

    Hello everyone,

    I will see what I to make little for the problems of FPS!

    But in my opinion for some among you that come from the shades although for more by these shades I them and put in static and not in dynamics which would cause to be even greedier,
    Thus for the moment while waiting for that I left in fixed and for those which encounter these problems to decrease the shades in your play,

    For the AIW it and truths that with certain MOD the IA do not pass well two turns and we however have make several time the AIW, with certain MOD that functions well and with other who are very fast the problems emerges,

    Cordially,
    Neel Jani

  • http://simracing.in.ua Pandamasque

    I run the rF version on GTX260 with shadows at medium (runs significantly faster at any track with very little visual difference). I experienced no FPS/memory problems whatsoever. But quite a lot of flickering textures. That’s terribly distracting. I wish I could take a screenshot of this, but it only happens in motion.

  • http://www.srrs-racing.net/ ermax18

    Wow.. This is a great improvement over the last MoSport. I am not having FPS problems at all. Not even a jitter here and there. I have a E6420 (stock clock) and ATI 5770 running 1920×1080. VSync off and “Max Framerate=”60″” in the PLR file. Everything set to full/max including shadows and shadow blur. AFx16 AAx8. +fullproc on the cmd line with 17 AI cars. This was using the NAGT2010 mod.

    I notice most of the shadows are static (built into the textures) so they shouldn’t create a FPS problem.

    I think the key to getting good FPS in rFactor is limiting the FPS in the PLR file (not talking about auto FPS menu) so it doesn’t peg your CPU at 100% and then run +fullproc. I don’t run VSync because of the massive controller lag it creates. But with Max Framerate=”60″ it almost completely eliminate tearing. Most LCDs don’t run over 60 anyways so anything over that is just making a heater out of your computer.

  • http://www.srrs-racing.net/ ermax18

    Oh, one more thing. I am not seeing any flickering textures. Maybe that is an Nvidia issue?

  • Neel_Jani

    ermax18: Wow.. This is a great improvement over the last MoSport. I am not having FPS problems at all. Not even a jitter here and there. I have a E6420 (stock clock) and ATI 5770 running 1920×1080. VSync off and “Max Framerate=”60″” in the PLR file. Everything set to full/max including shadows and shadow blur. AFx16 AAx8. +fullproc on the cmd line with 17 AI cars. This was using the NAGT2010 mod.I notice most of the shadows are static (built into the textures) so they shouldn’t create a FPS problem.I think the key to getting good FPS in rFactor is limiting the FPS in the PLR file (not talking about auto FPS menu) so it doesn’t peg your CPU at 100% and then run +fullproc. I don’t run VSync because of the massive controller lag it creates. But with Max Framerate=”60″ it almost completely eliminate tearing. Most LCDs don’t run over 60 anyways so anything over that is just making a heater out of your computer.

    Hello,

    I thank you for the high degrees of accuracy that you brought to us,
    Thus let us hope that those which one a problem will take note of your remarks and will apply these adjustments,

    Because for my part I do not have a current configuration and I do not have a problem of FPS with a full grid,

    Cheers,
    Neel Jani

  • CrippleHorse

    ermax18: Oh, one more thing. I am not seeing any flickering textures. Maybe that is an Nvidia issue?

    No, I have a geforce and don’t see any flickering at all.
    Maybe they’re refering to sparkling textures and not flickering? In that case, solution is easy, go to nvidia control panel, 3d settings, select rfactor and set negative LOD bias to “clamp”. This will stop the sparkles on the grass and trees, and on the road surface of many other tracks.

    Vsynch off (to stop steering lag), fullproc and frame limiter to 60 are sensible things to do anyway, but at least in my system they do not help with fps drops here.

  • http://www.srrs-racing.net/ ermax18

    Yeah I remember LOD clamp fixing strange texture problems on my old 8800GT. It is so strange that some are having problems and some are not. CrippleHorse, what CPU, GPU and OS do you have?

    BTW, Nvidia users should check out this guide over at RFC. It talks about LOD clamp and all that:
    http://www.rfactorcentral.com/detail.cfm?ID=Nvidia%20Graphix%20Settings

    Oh crap, I just remembered one other thing different on my setup. I use Wombat’s d3d9.dll. I know it says it is an Nvidia fix but it also helps on ATI cards:
    http://www.rfactorcentral.com/detail.cfm?ID=Nvidia%20FPS%20Fix

  • http://simracing.in.ua Pandamasque

    Sparkling, flickering… whatever )) I thought sparkling is more like a metallic paint effect, not whole polygons lighting up )

    I can’t use the ‘clamp’ thing because my card won’t engage any AF or AA, unless I use the default setting for quality where you can’t specify anything (the performance/quality horizontal bar thing). Is the a way to achieve the same results by editing the PLR?

  • http://www.srrs-racing.net/ ermax18

    That is odd. On my old 8800GT with the latest drivers as of about 4 months ago I was able to run AFx16, AAx8 and still set LOD to clamp. I set AA to app controlled, AA to override at 8x and then set AA in rF Config to 4x and then AF in the game to 16x.

    That guide I linked to goes over all the other setting in more detail. There is not way to set LOD to clamp in the PLR file as it is a driver thing.

  • http://simracing.in.ua Pandamasque

    Well I can actually turn all the filtering on in the nvidia advanced settings (and/or ingame) but it just won’t work (huge jaggies). I’ve no idea what’s wrong but it’s been this way since I upgraded to GTX260 (regardless of the drivers).

  • http://www.srrs-racing.net/ ermax18

    I had the same problem on my new ATI 5770. Regardless of settings it just would not do AA. But after a week of messing around I finally found a combination that worked. I made so many changes I don’t even know what the fix was. On the old 8800GT it was so simple though. If I remember correctly rF Config let me go as high as 6x but if I selected anything over 4x it would disable AA completely.. regardless of the Nvidia control panel settings. I had to set it to driver override at x8 AND 4x in rF Config.

  • deBorgo83

    Just gave this a try, I wasn’t familiar with Mosport from any other version/sim, but saw the ALMS race last year and thought it looked good. Isn’t it though!!! Drove the Enduracers Zytek, it’s terrific fun, and looks fabulous. No significant performance issues. Many thanks, Neel_Jani.

  • Neel_Jani

    Hello everyone

    Fix AIW and TDF Griplevel BY Flaux,

    Thank you with him,

    With installed in X:\ Program Files\Rfactor

    bond,
    http://www.nogripracing.com/details.php?filenr=26372

    Cheers,
    Neel Jani

  • http://www.srrs-racing.net/ ermax18

    So does this give more or less grip?

  • Neel_Jani

    ermax18: So does this give more or less grip?

    Hi,

    Yes

  • http://www.srrs-racing.net/ ermax18

    Hahaha.. Yes what?

    Which is it?:
    1. More Grip
    2. Less Grip

  • Neel_Jani

    ermax18: Hahaha.. Yes what?Which is it?:
    1. More Grip
    2. Less Grip

    :happyevil:

    Made a test!

    The AIW underwent some correction which corrects the problems with three turns T8, T9 & T2 with the cars too fast,

    And a little more grip in the TDF,

  • http://www.srrs-racing.net/ ermax18

    Cool, thanks. 🙂

Follow VirtualR: